Jump to content

Gozzie

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

1 Neutral
  1. Hello Lord Tim, Your suggestion is one of the very first things that I tried and it didn't work for me. I tried several other suggestions too and they didn't work for me either. I also did the aud delete, the folder delete and the reinstall. I suppose that it probably has to do with individual computers, versions of software etc.... because everyone seems to have various outcomes. i don't want to bore everybody with the whole story but maybe this can be another tool in the tool box for the next guy that has issues. I just bought a brand new Intel NUC Gen11i7pah computer with Windows 10 pro installed on it. My old laptop was getting pretty old and scary to rely on anymore. I installed Bandlab and then used it to install Cakewalk. Next I installed all the plugins and everything was fine. My trouble started when I moved my songs from the laptop to the NUC. The songs loaded just fine but the midi lagged drastically behind the audio. I opened up the piano roll on the drum track midi track and watched the behavior. When the pointer hit the drum beat, it took well over a 1/4 second for the sound to play. What caught my attention was that my bass midi track was playing in time. I closed the piano roll and noticed that I had frozen the bass track and that it was playing as an audio file and was in time with the rest of the tracks. So I unfroze the bass track it starting lagging the same as the midi drums. So I started my search on that issue. The suggested fix was to go back to the laptop and save my songs as a CWB file (cakewalk bundle extension) because it saves all of the timing data along with everything needed to transfer a song. So I did that but the problem still remained with lagging midi. Now I tried a simple experiment. I added a new midi track and placed a few drums beats on it. To my surprise the new drum beats stayed in time with the rest of the audio tracks while the original midi tracks lagged behind. What the heck. So I started my search on that issue. It was suggested that my old laptop WASAPI audio drivers were different than my new NUC drivers and that they could through off the timing. (that was actually right on the money) but here's what happened next. I went back to the NUC and started changing the audio drivers in cakewalk. I went from WASAPI shared to exclusive and there was no change. When I went from exclusive to WDM/KS cakewalk instantly crashed and wouldn't boot past the splash screen. So I started my search on that issue. I tried all of the suggestions that I found from you fine folks (many thanks) but nothing worked. The common part of all of the suggestions seemed to be that cakewalk was latching onto the audio drivers and just wouldn't let go. So I figured that if safe boot kept windows from loading the drivers just maybe something different would happen. I saw one forum article that talked about holding down the shift key when starting cakewalk to help resolve a bad plugin issue so that's what I did while in safe boot mode . Wala... I got the popup notice and was taken to the preference screen. I changed the audio driver back to WASAPI and rebooted the computer. Now cakewalk booted normally and all was good except for original midi lag problem. Now that I wasn't scared of the crashing issue anymore I went back to changing the audio drivers. I skipped over the ASIO driver because of the known ASIO4All issues and switched to MME. That fixed the lag problem YEAH !!! but I couldn't leave it alone at that so I tried another experiment. I opened up another old song with the MME driver and then saved it as another project. Then I changed the audio back to WASAPI shared and the song stayed in perfect timing. I loaded another old song and the timing was all off again with the midi lagging far behind the audio. So I repeated the process of changing the audio driver back to MME and saving the song. I changed the audio driver back to WASAPI and the timing was perfect again. So my fix for this was open old songs in MME and then save them. Now they will play right with whatever audio driver I choose at least for this computer. If I transfer to another computer this process may or may not work. I hope I dont have to find out anytime soon. How and why is way beyond me and I don't know if my fix will or won't help out the next person in line but hopefully it might keep someone from committing a violent act against their computer. I came all so close. Many thanks to you Lord Tim and everyone else who are out there trying to help out all of us keep up with the issues. You're a good dude. Gozzie
  2. Did you choose the wrong audio driver and now cakewalk wont boot past the splash screen? This fix is pretty simple and straight forward . I hope it can help you too. Windows 10 You have to reboot into safe mode. Once you are running in safe mode just hold the shift key down down when you start cakewalk. You will get a popup notice that will get you to the preference settings. Now you can choose the proper audio driver. Reboot the computer and restart cakewalk This seems to happen to a lot of folks but the advice to fix it is all over the map. There is no need to reinstall Windows 10 or Cakewalk by Bandlab. For me the WDM driver was the culprit. Let me know if this helped you out. Gozzie
×
×
  • Create New...