Jump to content

Mike Davies

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. As I posted on the thread in the Feedback Loop forum I think I have found it : Thanks to all who contributed to helping me out,
  2. OK, I think I have found it : I need to apply an <Insert Effect> instead of <Process Effect> in the above chain as follows : <Right-click on track to select MIDI data><Insert Effect><MIDI Effects...><Uncategorised><Transpose> and set <Offset> to <3> That leaves the notes in the Staff view unchanged while lowering the pitch of the produced sound. Thanks again for all the help and replies,
  3. I believe so. I have the track in the main view with the Staff showing in the view below. I perform as follows : <Right-click on track to select MIDI data><Process Effect><MIDI Effects...><Uncategorised><Transpose> and set <Offset> to <3> The notes in the Stave view of the track immediately update to match the new midi data which is overwritten in the track. Re-opening the <Transpose> control shows it is now set to zero and if I want the MIDI data to be returned to its original state then I need to set the offset to <-3> and re-apply it.
  4. Hi Promidi, Thanks for your suggestion, which was also made in the thread I linked. Unfortunately, this has the effect of changing the notation in the Staff view to the concert pitches of the notes which is not the required and documented behaviour. I am aware of another workaround which will work but is very clunky to use and that was also given in the linked thread. I was using this thread as a specific feature request/bug fix request and for comments by the team on these features generally rather than a search for a workaround. Thanks again,
  5. Hi, I put a full description of my issue on this thread along with some pix. Briefly, If I go into the Track Inspector from a Staff view and input an offset (-9 in my case) into the "Key+" field then the output pitch is dropped by 9 semitones as required but the key signature and note notation displayed in the Staff view changes, which is not required. As far as I can see from page 287 of the manual, it is intended that the software works as I would like : If there was any way to prevent the key signature and corresponding notation change then this facility would be perfect for my needs, and, I suspect, the needs of most players of transposing instruments as well. Also, as an aside, a product enhancement that would be really useful would be for the key selection that is currently used only for note snapping to pitch to be the thing that is responsible for setting the key signature in the Staff view, instead of the software apparently choosing it on its own as currently. Many thanks,
  6. Thanks. It does seem as though the intended behavious of the Key+ facility is as I need though, from the manual on page 287 : Thanks again,
  7. If I do that with an offset of (-9) then MFX changes the MIDI itself so that the Staff view is shown with the music transposed 9 semitones lower as in the pic "0key_cmaj_transp_minus9.jpg" below. This is also not what I need which is for the Staff view to remain unchanged but the sounded output to be shifted down by 9 semitones. I should say that I'm completely blown away by how good Cakewalk is as free software, just a pity I don't seem to be able to get exactly what I need from this. Is there an enhancements "suggestions box" for the developers anywhere ? I'm sure there are lots of transposing instruments players out there who could do with the facility I am looking for. Thanks for the replies,
  8. Hi, I am using Cakewalk as an aid in trying to learn Alto sax and I have run into an issue. For those not familiar the Alto Sax is a transposing instrument and music written for it is written on a Treble clef stave and it plays 9 semitones lower than as written. I have found the "Key+" facility in the Track Inspoector and the page on "Music notation for non-concert-key instruments" on page 1258 of the latest manual but I have an issue as follows : For example, say I want to score the following notes for the AS in a key of C Major : Bb, B, C, Db (concert pitches Db, D, Eb, E) it is usual for the part to be written as in the first pic below named "0key_as_cmaj.jpg". BUT, if I try to do as is suggested on pg 1258 of the manual and notate for the instrument then add (-9) in the "Key+" field of the Track Inspector the Staff view gains 3 "#" symbols turning it from C Major to A Major with the C notation changing to C♮ and the Db to C without any accidental applied as per the second image file "9key_as_amaj.jpg" attached (but of course the A Major scale does have the C# in the key signature so it is technically correct as far as that goes). Is there any way to have the minus 9 semitone offset I require for the output to sound at the Alto sax pitch, while still having the notation that is normal for the AS in the Staff view ? I tried messing around with key signatures but it seems they have no effect on the notation in the staff view, only on the note snapping as you enter notes. To be completely clear, what I need is for the music I enter on the Staff view to remain unaltered when I apply the (-9) offset in the Key+ field but just for the output pitches to be lowered. Thanks,
×
×
  • Create New...